the forums at

It is currently Thu Apr 15, 2021 8:02 pm

All times are UTC - 7 hours [ DST ]

Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 75 posts ]  Go to page 1, 2, 3, 4, 5  Next
Author Message
PostPosted: Sat Aug 07, 2004 3:04 am 
[Please note i am working with a BEFSR41 v.2 router with 1.46.00, Jun 24 2004 Firmware!]

Ive been trying to get the green light with Bit Tornado for 2 days now and have read countless posts on many forums on how to configure the BEFSR41, most of which didnt work. This is how i finally managed to sort it:


1) Open the Linksys router configuration by going to [or whatever you have changed it to]
2) Click the advanced link - Then the forwarding link
3) Under Customised Applications enter BitTorrent, then under Ext. Port enter a number between 10000 and 60000. With whatever number you have chosen add 20 to get the second number. These are the port ranges Bit Torrent will be operating on. [For an example, 15000 and 15020]
4) Place a check under Protocol TCP, and forward to whatever IP address you will be running Bit Torrent on - Then check the enable box! Then click the Apply button at the bottom.
5) Before you exit the router configuration click the Setup link, then the Status link. Find the WAN IP address option and take note of this number!

Bit Torrent Configuration

1) Download the conectionchecker.torrent file [ ]
2) Run this .torrent file and click on the Prefs link.
3) Under the Port Range option enter the numbers you noted down while setting up the router! [Our example is 15000 and 15020] - Then uncheck the randomise checkbox
4) Click the advanced button. Then under the Local IP option put in the IP address you noted in the Status configuration of the router earlier.

Click ok, Click Save, then restart BitTorrent and run the connectionchecker.torrent again - If with my ISP i passed the NAT check but had an invisible proxy, "Best you can do"..

Now run off to whatever Torrent Index you use and download something to try it -

I hope ive helped somebody, this message took long enough to type :?

 Post subject:
PostPosted: Sat Aug 07, 2004 3:10 am 

1) I am also running Sygate Free Firewall, i did not need to configure this to allow BitTorrent to work -

2) Now just disable the WindowsXP firewall (its useless anyway, get a better one!)

- Click Start
- Click Control Panel
- Click Network Connections
- Right click on your connection and click properties
- Click the Advanced Tab, Then make sure the checkbox is UNCHECKED!

 Post subject:
PostPosted: Sat Aug 07, 2004 4:25 am 
Note that entering your WAN IP in the "Local IP" field is only needed if you have problems with a (transparent) proxy. You will also need to re-enter it whenever your WAN IP changes.
You can leave the port randomizing enabled if your forwarded/opened ports match with the bittornado settings (they're supposed to match anyways).

 Post subject:
PostPosted: Mon Aug 09, 2004 3:44 am 
Thank you for posting this info. Fixed me right up.

 Post subject:
PostPosted: Mon Aug 09, 2004 7:40 pm 
Thanks it worked.

 Post subject: worth a try
PostPosted: Tue Aug 10, 2004 8:22 pm 
hey, thanks for the tip...just upgraded my shadow client and have not been able to get a green light yet. Am also using the linksys router, and have done the normal port forwarding but your tip makes sense - will try it out as soon as i get home. just figured since you took the time to help out, i can certainly take the time to post my appreciation.....mahalo from honolulu 8)

 Post subject:
PostPosted: Thu Aug 12, 2004 12:34 am 
i just tried to configure my router but it gives me a password message... i never set a password for it... what would the default password and username be? administrator or something? please help....

 Post subject:
PostPosted: Thu Aug 12, 2004 12:49 am 
nvm problem fixed... the username is blank and the password is admin btw

 Post subject:
PostPosted: Thu Aug 12, 2004 9:54 am 
Unfortunately, still not working for me. Perhaps it is complicated by my having an Origo ASDL modem before my Linksys BEFSR81 Router. I tried the Linksys WAN address in the Local IP, but get an error message:

ERROR (04:51PM)
rejected by tracker -- Client sent IP address 10:0.0.7
10.x.x.x is unacceptible.

My LAN is on 192.168.1.x

I've also tried enabling DMZ mode, but no luck.


 Post subject:
PostPosted: Fri Aug 13, 2004 9:36 am 
OK, I think I now have this resolved. In addition to my Linksys BEFSR81 router (similar to BEFSR41), I have an Origo ADSL ASR-8000 modem router which feeds into my Linksys 8-port router. The following changes to the Origo ADSL modem are required:

1. Find your Linksys WAN IP address. Go to (enter username and password), and an go to the Linksys Status screen. My WAN IP address shows as

2. Go to the Origo configuration screen at (and enter username and password).

3. Select the "Virtual Server" menu.

4. In the two Public Port - Start & End boxes, and the Private port box, enter the port used by BitTornado (I've also tried this with Azureus).

5. In the Host IP Address, enter your WAN IP address, in this case and click Add This Setting. Repeat for other Port numbers in your range.

6. Save setting and reboot.

7. Of course the Linksys router also needs to forward the ports. So on the Linksys menu, go to Advanced | Forwarding, and enter your ExternalPort range, specify TCP, and you own PC's IP address. Eg. (you can check this on the Setup | DHCP pages (click DHCP Client table button).

The Azureus Bit Torrent client was help in solving this problem as it has a TEST button which shows "Nat Fail" or OK.

Ian Tresman

 Post subject:
PostPosted: Fri Aug 13, 2004 6:26 pm 
I have a Befsr41 V3

i have no idea where the wan ip is on this thing or how to get it to work, it looks the same, and i found the forwarding part, but i can't seem to find the wan ip, or to get it to work with getting rid of the yellow light

 Post subject:
PostPosted: Fri Aug 13, 2004 6:27 pm 
would the DMZ help?

 Post subject:
PostPosted: Tue Aug 17, 2004 12:25 pm 
maybe this would help anyone to understand a bit

there u will find a wide range of port opening n triggering.


PostPosted: Fri Aug 27, 2004 2:18 pm 
Wow, with this advice, in conjunction with advice on fiddling with my XP Firewall
( ), I finally got a green light and download speeds upwards of 300 kb/s! Thanks, y'all.

Before today I always just figured that the yellow light and speeds of up to 20-30 kb/s were as good as it could get with BitTorrent, despite occasionally getting speeds of 150 kb/s and up with other P2Ps. My extremely limited technical knowledge made me reluctant to screw with any IP, router, or firewall settings. But the advice here and in other threads concerning the Linksys BEFSR41 router was actually simple enough for me to understand, and I finally got a green light. Only after I fiddled with the XP Firewall did it finally work, so I'm wondering if some of the other things I did before that were really necessary.

For instance, I followed the advice in this thread: ... including the stuff at about setting a static IP. Is that really necessary? Couldn't this eventually cause problems? Forgive my ignorance but don't ISPs occasionally fiddle with the IP addresses? I think somebody at my ISP once told me specifically that I should leave it set for "obtain an IP address automatically." But maybe that's advice for complete and total ignoramuses (although I'm not far from being of one those).

Woah, I just busted past 400 kb/s download speed and everything else on my computer slowed waaaaaay down, including this browser. I've got the bandwidth but not the RAM! Can't seem to figure out how to throttle it down a little without restricted the upload rate to a ridiculously low level, but ... now the download is finished and I'm just uploading. So I guess it won't matter again until I download something else.

PostPosted: Sat Aug 28, 2004 6:08 am 

I have followed the advise above and get a green light. But when I use NatCheck ( it always fails.

Just to be sure I changed the port range in BitTornado to just 6881 (from and to) so I can be sure which port is being used. I have disabled my firewall (ZoneAlarm) and the WinXP one has always been disabled.

Curiously though NatCheck says:

Attempting connect to: port 6881
Unable to connect. This likely means you need to adjust your port forwarding configuration, or there is no client running on that port.

But my ip (from router setup page) is

Can anyone help please.[/b]

Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 75 posts ]  Go to page 1, 2, 3, 4, 5  Next

All times are UTC - 7 hours [ DST ]

Who is online

Users browsing this forum: No registered users and 10 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group