the forums at degreez.net

It is currently Sun Dec 10, 2017 6:11 pm

All times are UTC - 7 hours [ DST ]




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 25 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Fri Nov 11, 2005 10:48 am 
This guide is for those who HAVE NOT port forwarded and wish to use the uPnP functions of Bittornado. You MUST have a router that supports uPnP. This may fix your yellow light - as it did for me.

Note that you must be a system administrator to do some of this stuff.

Most of the problems are to do with the uPnP services not being installed - this guide aims to help you with doing exactly that in windows XP.

Checking if uPnP is the problem

1. First we must make absolutely sure that uPnP isn't working. Open a torrent and click 'Advanced'.

2. near the bottem, you should see this (where '#####' is a number):

Listening on port #####

If you have this and then 'uPnP port forwarded' after it - uPnP is not the cause of your yellow light. If not, carry on!

Making sure the settings are correct

1. Click the prefrences button:

Image

2. Make sure the uPnP option is on 'type 1 (fast)':

Image

3. Close the preferences window.

4. Close Bittornado

Installing the correct components

1. Click start ---> Control Panel ---> Add or Remove Programs

2. Click 'Add/Remove Windows Components' on the left:

Image

3. Wait until the window loads.

4. Scroll down to networking services:

Image

5. Double click on it.

6. Make sure the following things are ticked:

Image

NOTE: If you have more options ticked - LEAVE THEM TICKED - you dont want to mess anything up. But these 3 are the most important (especially the last one).

ANOTHER NOTE: These already ticked? Move onto the next section.

7. Click OK.

8. Click Next.

9. Wait until the process completes.

10. Click finish

11. Close Add or Remove Programs and the Control Panel (if not done so already).

Making sure the correct services are running

1. Click Start ---> Control Panel ---> Performance and Maintenence ---> Administrative Tools.

2. Double click 'Services'.

3. Scroll down to 'Plug and Play'.

4. Right-click and select properties.

5. Make sure 'Startup type' is set to 'Automatic'.

6. Click apply and then OK

7. Repeat this process for the following services:

SSDP Discovery Service
Universal Plug and Play Device Host

NOTE: If you receive errors next time you boot up - disable the 'Universal Plug and Play Device Host' - it is the least important and may not help anyway.

8. Close all windows.

9. Reboot your PC.

Did it work?

Now you can run bittornado and hold your breath. In my case I saw the glorious green colour pierce my eyes - I hope you do too!

Hope that helped,
Adam


Top
  
 
 Post subject:
PostPosted: Wed Nov 23, 2005 9:26 am 
Hi

what if i dont have install internet gateway device discovery and control client and Ipv6 on the list?


Top
  
 
 Post subject:
PostPosted: Wed Nov 23, 2005 9:42 am 
make sure universal plug and play is ticked.


Top
  
 
 Post subject:
PostPosted: Wed Nov 23, 2005 9:45 am 
it is but i still dont have internet gateway device discovery and control client or ipv6 on the list


Top
  
 
 Post subject:
PostPosted: Wed Nov 23, 2005 11:56 am 
it didn't go green for me... :cry:


Top
  
 
 Post subject:
PostPosted: Thu Nov 24, 2005 10:53 am 
Sorry to see it didnt go green.

For the other guest:

If there not on the list - it really doesnt matter. Just make sure plug and play is ticked and move onto the next section.


Top
  
 
 Post subject: Enabling UPNP
PostPosted: Mon Dec 12, 2005 1:21 am 
Do I need to have a UPNP-aware router for UPNP to work. How do I know if my router is blocking UPNP packets or not? I have the 2Wire 1700 HG DSL gateway which has NAT, but says nothing about UPNP.


Top
  
 
 Post subject:
PostPosted: Tue Dec 20, 2005 9:56 am 
This walkthru actually did it for me! Thanks alot
Z


Top
  
 
 Post subject:
PostPosted: Mon Dec 26, 2005 11:47 am 
Glad to here my walkthrough work.

You do need a uPnp aware router. You know its blocking if you have upnp enabled and you still get yellow light - upnp is not functioning.

Possible pin on this topic?


Top
  
 
 Post subject:
PostPosted: Tue Dec 27, 2005 8:06 am 
using upnp will be faster than port forwarding(manual)?


Top
  
 
 Post subject:
PostPosted: Tue Dec 27, 2005 7:27 pm 
goodboi wrote:
using upnp will be faster than port forwarding(manual)?

No, UPnP is almost always slower than port forwarding. UPnP puts a bigger load on your router and your CPU, as they both have to actively manage UPnP -- whereas port forwarding is done entirely by the router.

Many routers that can do UPnP also do not do it well under heavy loads -- either bandwidth speeds drop off or the router even crashes.


Top
  
 
 Post subject:
PostPosted: Fri Jan 06, 2006 10:59 am 
What he said is half-true.

The latest routers never suffer these problems and you do not experience a noticable slow down during uPnP.

However, I do agree that port forwarding is safer, but if this gets the green light then so be it!


Top
  
 
 Post subject:
PostPosted: Fri Jan 06, 2006 2:11 pm 
Even the latest HOME (meaning not business-class) routers have limited UPnP tables. Often it's only 256, 512, or 1024 entries allowed at once. What that means is UPnP may work "perfectly" so long as there's fewer than 256, 512, or 1024 connections at once. Routers also have relatively slow CPUs in them compaired to PCs, so handling lots of connections + UPnP can cause (very) minor slowdowns.

Some really crappy routers can only handle that many connections of any kind period.


Top
  
 
 Post subject:
PostPosted: Mon Jan 09, 2006 4:28 pm 
it works fine...thanks a lot...


Top
  
 
 Post subject:
PostPosted: Thu Jan 12, 2006 2:43 pm 
Great guide... it helped me get a green light once, but once I exited the torrent & started it back up, I got the yellow light again. It no longer said the UPnP port was forwarded.

Any advice for this?

Thanks in advance.


Top
  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 25 posts ]  Go to page 1, 2  Next

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group