the forums at degreez.net

It is currently Sat Nov 17, 2018 4:47 am

All times are UTC - 7 hours [ DST ]




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 7 posts ] 
Author Message
PostPosted: Fri Mar 26, 2004 11:25 am 
I'm trying to install bittornado under red hat 9. The problem is that i cant get to the point of acually installing bittornado because it needs python2.3 but redhat 9 has/uses/needs python2.2. Can anyone with some linux experience help me out?


Top
  
 
 Post subject:
PostPosted: Sat Mar 27, 2004 1:38 pm 
Offline

Joined: Sun Mar 07, 2004 10:05 am
Posts: 1212
BitTornado should *not* require Python 2.3. Please let me know of any errors you are experiencing because of running it with an older Python version and I will fix them.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Mar 28, 2004 9:27 am 
Offline

Joined: Fri Mar 26, 2004 2:11 pm
Posts: 2
i'm using mandrake 9.2, i have python 2.3 and wxPython installed... 5.8.11 run fine in my system, just cant get bittornado running... :(

let me tell you how i run it... i usually download the torrent files in my local drive then run it with bittorrent... but when i use, or assign bittornado btdownloadgui.py to run... its just nothing happened... no error msg.. no nothing... :(

is anyone there have anyidea whats wrong with my system?? thankz...


Top
 Profile  
 
 Post subject: the error
PostPosted: Tue Mar 30, 2004 3:42 pm 
Hi... I thought I speed up the process since I have the same problem ...
the error is pasted below, I use RH9 with Python 2.2.2 and wxPython 2.4.2.4...
Thanks for your help !

---------------------------------------------------------------------------
[xxxx@xxxxx BitTornado-CVS]$ ./btdownloadgui.py
Traceback (most recent call last):
File "./btdownloadgui.py", line 7, in ?
from BitTornado import PSYCO
File "./BitTornado/__init__.py", line 49, in ?
resetPeerIDs()
File "./BitTornado/__init__.py", line 32, in resetPeerIDs
t = int(time()*100)
OverflowError: float too large to convert
----------------------------------------------------------------------------


Top
  
 
 Post subject:
PostPosted: Tue Mar 30, 2004 8:52 pm 
Offline

Joined: Sun Mar 07, 2004 10:05 am
Posts: 1212
Huh. Weird. I wouldn't expect that to happen, my time() function should return the same as yours, shoudn't it?

Anyway, I'm switching the int conversions to long, which should fix the problem.

Cheers.


Top
 Profile  
 
PostPosted: Wed Mar 31, 2004 6:46 am 
I used 5.8.11 with no problem.

./btdownloadcurses.py
Traceback (most recent call last):
File "./btdownloadcurses.py", line 8, in ?
from BitTornado import PSYCO
File "./BitTornado/__init__.py", line 49, in ?
resetPeerIDs()
File "./BitTornado/__init__.py", line 32, in resetPeerIDs
t = int(time()*100)
OverflowError: float too large to convert

rpm -q python
python-2.2.1-17

rpm -q wxPythonGTK-py2.2
wxPythonGTK-py2.2-2.4.0.2-2

i installed PSYCO with no change


Top
  
 
 Post subject:
PostPosted: Wed Mar 31, 2004 8:20 am 
Offline

Joined: Sun Mar 07, 2004 10:05 am
Posts: 1212
Okay. This will be fixed in the next release.


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 7 posts ] 

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group