the forums at degreez.net

It is currently Wed Jul 26, 2017 8:39 am

All times are UTC - 7 hours [ DST ]




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 45 posts ]  Go to page Previous  1, 2, 3
Author Message
 Post subject: gentoo package collision
PostPosted: Tue May 31, 2005 11:43 pm 
You should be able to solve it with:
Code:
emerge --unmerge net-p2p/bittorrent


Top
  
 
 Post subject:
PostPosted: Thu Sep 15, 2005 2:15 pm 
revellion wrote:
State your distro and i'll help out 8)

EDIT:

These steps should work for most GNU/Linux users.

you'll need python and wxpython.

After that it's very simple, just copy the .py family of btdownloadgui.py and company to /usr/bin

then if your using mozilla or firefox and click on a .torrent tell it to open it. and fill in the Open with field with "btdownloadgui.py" and it should work fine :D



I'm using suse 9.3 but thiis isn't working for me, i have installed both python and wxpython but when i open a torrent file in firefox and ask it to upen the file using btdownloadgui.py i get an hourglass for a few seconds, then nothing. Same happends if i just run btdownloadgui.py by itself


Top
  
 
 Post subject:
PostPosted: Sun Oct 23, 2005 9:58 pm 
ok i'm just a total newbie at this thing...and i dont know if this will even help anyone but i found a site that has a tutorial on bittornado or watever

http://www.afterdawn.com/guides/archive ... ornado.cfm

if i dont even know what the hell im talking about, sorry. hehe :)


Top
  
 
 Post subject:
PostPosted: Mon Nov 14, 2005 9:06 am 
Archive.org has a mirror of that guide here:
http://web.archive.org/web/200406300357 ... uxtorrent/


Top
  
 
 Post subject:
PostPosted: Tue Nov 15, 2005 8:32 pm 
I would hope that someone is still monitoring this thread...

I'm a gentoo user and have emerged bittornado today. I would assume that portage like everything else emerges the dependencies as well automatically, such as wxpython. however this does not seem to be the case.

Also, I looked in /usr/bin and could not find any btdownloadgui.py but found these instead:

bt-t-make.py
btcompletedir.py
btcopyannounce.py
btdownloadcurses.py
btdownloadheadless.py
btlaunchmany.py
btlaunchmanycurses.py
btmakemetafile.py
btreannounce.py
btrename.py
btsethttpseeds.py
btshowmetainfo.py
bttrack.py

I have several partially downloaded torrents, but was looking for a good linux based bittorrent client, since I got tired of windoze and its horrible inefficiency in bandwidth. In addition to this, I also have a few torrents to seed as well, and heard a few good things about this client...anyways. Thanks for the help...


Top
  
 
PostPosted: Sun Nov 20, 2005 10:44 pm 
ziggyboy wrote:
I have created a guide on how to use BitTornado on Linux/Unix (might work on OS X CLI).

http://sogono.com/carlo/linuxtorrent/

Thanks.


Top
  
 
 Post subject:
PostPosted: Wed Nov 30, 2005 12:56 pm 
happyoutkast wrote:
I would hope that someone is still monitoring this thread...

I'm a gentoo user and have emerged bittornado today. I would assume that portage like everything else emerges the dependencies as well automatically, such as wxpython. however this does not seem to be the case.


Make sure you have "gtk" in your USE-flags, look at /etc/make.conf or enable it once while emerging bittornado with
" USE="gtk" emerge bittornado "


Top
  
 
 Post subject: wxPython and USE Flags
PostPosted: Wed Jan 04, 2006 1:02 am 
Just updated to gcc-3.4.5 on my Gentoo install and recompiled <i>everything</i> (literally: took about 50 hours to compile 129 packages in system and 654 in world. <i>I</i> thought it was hilarious) Of course, like any 3.3* to 3.4* switch, I broke a few things....like BT. I had this problem before and the error message told me I had to compile wxPython without a certain flag. Now all I get is "wxPython is either not installed or has not been installed properly." Real bummer. Anyways, of the four flags it (wxPython) was compiled with, is it the gtk2, opengl, or unicode flag that's giving me grief?

PS: Yes, it was working before.

PPS: Current version is wxpython-2.6.1.0


Top
  
 
 Post subject: Fixed...presumably
PostPosted: Fri Jan 13, 2006 9:04 am 
It seems wxPython cannot be compiled with gtk2 (and therefore also without unicode) which seems to mean wxGTK needs to be compiled with
Code:
USE="-unicode wxgtki" emerge wxGTK


Top
  
 
 Post subject:
PostPosted: Mon Jan 16, 2006 12:53 pm 
Since people still seem to be having trouble with this, and since some instructions given so far seem kind of bogus (one link's installation instructions are "download this"), I thought I'd try to help...

Assuming your problem isn't getting wxPython compiled on Gentoo (my answer for that is don't use Gentoo :)):

(If you're just having problems getting torrents to launch from a browser, skip to the end and try that first.)

0. If you're using packages, just reinstalling them may take care of everything.

0.5. If you're copying files manually, just remember to copy the BitTornado directory too; it needs to be in the same directory as the bt*.py files, or in one of the python lib directories. (This bit seems to be missing from some suggestions. If this fixes things, great, you're done.)

1. It's possible that different bittorent clients and leftover files are conflicting with eachother. Uninstall any bittorrent / bittornado / etc packages, and delete any remaining bittorrent related files (bt*.py) and directories (BitTornado, Bittorent) from anywhere in your path and anywhere Python looks for them. If you don't know where those are, look in /usr/bin, /usr/local/bin, /usr/lib/python2.x and /usr/lib/python2.x/site-packages, and python2.x and python2.x/site-packages in /usr/local/lib. (Don't delete everything in /usr/lib/python2.x. That would be bad. Well, you'd just have to reinstall python and most things that use it. Also /usr/bin. That would be VERY bad.)

2. Download and untar bittornado.

3. If you don't care about launching torrents directly from a browser, the easiest way to run bittornado is to go to the directory and run it from there. Regardless, read docs/INSTALL.unix.txt, it has directions for getting torrents to launch from a web browser. It also gives the easy directions for installing, run: python setup.py install
(After running the setup script, the directory can be deleted.)
(It's probably best to just run the setup script than copying files manually - see 0.5.)

For completeness, and for the lazy, the contents of INSTALL.unix.txt:
Code:
install Python, version 2.0 or later - http://python.org/

install wxPython - http://wxpython.org/

(under debian, you can currently get the above using
apt-get install libwxgtk2.2-python
from testing and use python 2.1)

untar and run: python setup.py install

put a line in /etc/mailcap which is similar to the
following, only replace the path to
/usr/bin/btdownloadgui.py with the one it's actually in.

application/x-bittorrent; /usr/bin/btdownloadgui.py %s; test=test -n "$DISPLAY"

You may have to restart your web browser for it to start
using BitTorrent.

If you're using a web browser which doesn't respect
/etc/mailcap you can go into the mimetype configuration for
your web browser and manually associate application/x-bittorrent
with btdownloadgui.py (with the appropriate path, of course.)



Hope this helps. :)


Top
  
 
 Post subject: Grrr
PostPosted: Fri Jan 27, 2006 4:41 pm 
"python: can't open file 'setup.py'" I give up. the hard drive is ging in the microwave (why not) and the rest of this thing is getting shot. Repeatedly. Guess I'm just not supposed to use linux. I'm going back to windows. Maybe I should just shoot myself instead. It would be less painful than windows...


Top
  
 
 Post subject:
PostPosted: Sun Mar 05, 2006 9:06 pm 
Hello there boys and girls. I will write a little guide here on how to install the latest version of BitTornado on your Ubuntu Breezy system. This probably works on Debian as well. :)

1. Download BitTornado-0.3.15.tar.gz
2. Python should already be installed, but just to make sure:
Code:
sudo apt-get install python2.4
sudo apt-get install python

3. Install dev tools for Python:
Code:
sudo apt-get install python-dev

4. Install wxPython:
Code:
sudo apt-get install python-wxgtk2.6

5. Unpack BitTornado-0.3.15.tar.gz if you haven't done so already.
Code:
tar -zxvf BitTornado-0.3.15.tar.gz

6. Change directory to new folder:
Code:
cd BitTornado-CVS

7. Run install script:
Code:
sudo python setup.py install

8. Edit default MIME types:
Code:
sudo cp /etc/mailcap /etc/mailcap_backup
sudo gedit /etc/mailcap

Search for "torrent" and delete the found lines.
Append this line at the bottom:
Code:
application/x-bittorrent; /usr/bin/btdownloadgui.py %s; test=test -n "$DISPLAY"

9. Restart your web browser and have fun. :)


Top
  
 
 Post subject:
PostPosted: Sun Mar 05, 2006 10:16 pm 
Offline

Joined: Wed Apr 21, 2004 9:19 pm
Posts: 37
Well I forgot to log in before I posted the above so I can't edit it. :-/

If you want you can create a link to BitTornado in your menu by using the Applications Menu Editor. Just choose Internet and then press the New Entry button. Mine looks like this:

Name: BitTornado
Comment: Download files with BitTornado
Command: /usr/bin/btdownloadgui.py

You can get some application icons for BitTornado here:
http://www.deviantart.com/view/28014374/

Just drop them in /usr/share/icons or /usr/share/pixmaps


Top
 Profile  
 
 Post subject:
PostPosted: Wed Mar 08, 2006 5:36 am 
would anyone post a tutorial for installing BT on SUSE 9.3 ?
All tuts are down :(

thx


Top
  
 
 Post subject:
PostPosted: Sat May 12, 2007 8:41 am 
Offline

Joined: Sat May 12, 2007 8:36 am
Posts: 1
well.
here's a dirty hack to get latest working in ubuntu/debian as i cant seem to find a guide that actually worx. the reason i had to figure this much out is because one of hte sites i go to requires latest stable bittornado.

1. install bittornado
sudo apt-get install bittornado #this is for commandline
sudo apt-get install bittornadogui #this is for gui
2. download source and extract - say to ~/ for our example
cd ~/Bittornado-CVS
sudo rm -R /usr/lib/python2.4/site-packages/BitTornado/
sudo mv BitTornado/ /usr/lib/python2.4/site-packages/

done :)
the system will lie to you and tell you its version .13 or whatever is in the repos that you use - but sites will see that its a good updated version :)


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 45 posts ]  Go to page Previous  1, 2, 3

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group