the forums at

My Torrents onn Linux/Unix guide (maybe OS X CLI too)
Page 2 of 3

Author:  Guest [ Fri Nov 19, 2004 1:23 am ]
Post subject: 

revellion wrote:
State your distro and i'll help out 8)


These steps should work for most GNU/Linux users.

you'll need python and wxpython.

After that it's very simple, just copy the .py family of and company to /usr/bin

then if your using mozilla or firefox and click on a .torrent tell it to open it. and fill in the Open with field with "" and it should work fine :D

thanks this helped a lot. I'm a new gentoo user and after emerging bittornado (which also emerged python and wxpython), all I had to do was tell firefox to open the .torrent file with /usr/bin/

Author:  Guest [ Sun Nov 28, 2004 2:22 am ]
Post subject: 

hmm.. really? I did that but I'm getting the the regular btwindow..
I'll try to unmerge bittornado and bittorrent then remerge bittorando

Author:  Andrew [ Wed Dec 01, 2004 2:35 am ]
Post subject: 

I'm using Mandrake 9.2 - Downloaded the tar.gz and exported it, the top level looks like straght unix bittorrent (already had an rpm for that) how do Iinstall bittornado?

Author:  aefkei [ Wed Dec 08, 2004 5:36 pm ]
Post subject:  mime types

The mime type extension manager for Firefox can be downloaded from : ... ype-editor


Author:  Takumi68 [ Sat Jan 15, 2005 4:40 pm ]
Post subject: 

hello, if anyone still comes to this post, I have SUSE 9.2, and i have copied the files to usr/bin. i have python and wxpython installed. when i try to open a .torrent file, i get the hour class and no gui. I am opening it with ""

Any suggestions?


Author:  Takumi68 [ Sat Jan 15, 2005 4:46 pm ]
Post subject: 

sorry, i figured out the problem wxpython was not installed properly. can anyone help me install it under my distro? (im a linux newb) distro is suse 9.2

Author:  Guest [ Thu Jan 20, 2005 12:10 pm ]
Post subject: 

revellion wrote:
State your distro and i'll help out 8)

my distro: debian linux with the newest kernel (6.10 i think)
i downloaded bittornado with apt-get and i don't have a user interface.
how can i use bittornado from command line?
(link is also fine)

thanks :)

Author:  Guestaru [ Tue Jan 25, 2005 8:20 pm ]
Post subject: 

try using
without anything following the commando you will get an overview of the options you can use
(you might want to bind the commando + the options to an alias, it's a "mouthfull" to type it all out every time)

Author:  Guest [ Sat Feb 12, 2005 6:03 am ]
Post subject: 

Thank you Guestaru :D

Author:  bitkocher [ Sun Feb 13, 2005 9:22 am ]
Post subject: down

instead "Domain for sale" appears. So that thread should be deleted...

Author:  Guest [ Fri Mar 11, 2005 7:10 am ]
Post subject:  Re: My Torrents onn Linux/Unix guide (maybe OS X CLI too)

ziggyboy wrote:
I have created a guide on how to use BitTornado on Linux/Unix (might work on OS X CLI).


it's not available now! Coul you give another url?

Author:  guhase [ Sat Mar 12, 2005 12:23 am ]
Post subject: 

I get this error when i try to run torrents with can someone help?

running slackware with python and wxpython installed.

BitTorrent T-0.3.10 (BitTornado)
OS: linux2
Python version: 2.4 (#1, Jan 1 2005, 21:33:55)
[GCC 3.3.4]
wxWindows version:

Traceback (most recent call last):
File "/home/guhase/Desktop/BitTornado-CVS/", line 477, in onInvoke
apply(event.func, event.args, event.kwargs)
File "/home/guhase/Desktop/BitTornado-CVS/", line 2000, in onChooseFile
style = wxSAVE)
File "/usr/lib/python2.4/site-packages/wx-2.5.3-gtk2-unicode/wx/", line 2359, in __init__
newobj = _windows_.new_FileDialog(*args, **kwargs)
PyAssertionError: C++ assertion "nLen != (size_t)-1" failed in ../src/common/string.cpp(1060)

Author:  nosie [ Thu Apr 14, 2005 1:16 am ]
Post subject: 

Hi @ all!

I get this mesage:

BitTorrent T-0.3.10 (BitTornado)
OS: linux2
Python version: 2.3.4 (#1, Feb 7 2005, 15:50:45)
[GCC 3.3.4 (pre 3.3.5 20040809)]
wxWindows version:

Traceback (most recent call last):
File "/usr/bin/", line 477, in onInvoke
apply(event.func, event.args, event.kwargs)
File "/usr/bin/", line 2020, in onChooseFile
self.onChooseFileDone(default, size)
File "/usr/bin/", line 2030, in onChooseFileDone
self.fileNameText.SetLabel('%s' % (lname))
File "/usr/lib/python2.3/site-packages/wx/", line 8353, in SetLabel
return _core_.Control_SetLabel(*args, **kwargs)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 8: ordinal not in range(128)

What is the reason for?

Author:  alpha [ Mon Apr 18, 2005 8:51 pm ]
Post subject:  Re: My Torrents onn Linux/Unix guide (maybe OS X CLI too)

hello all, I have some issue installing bittorent in Gentoo:
The problem is I by mistake installed first bittorrent-3.4.2-r2
now if I
$ emerge -pv =net-p2p/bittornado-0.3.8
[blocks B     ] net-p2p/bittorrent (is blocking net-p2p/bittornado-0.3.8)
[ebuild  N    ] net-p2p/bittornado-0.3.8  +X 215 kB

but trying
<03:40:01> - root 'at' alpha - ~
emerge -c net-p2p/bittorrent-3.4.2-r2

>>> clean: No packages selected for removal.

so it seems can't find a so named package (I've tried also the simple emerge -c bittorrent)
Note: the log of the installation of bittorrent-3.4.2-r2 have no errors so I think is some bug in the packaging/ebuild
I hope someone can advice me.

I have looked at
ziggyboy wrote:

but it seems is rederecting elsewhere ... can someone update the link to a new source?

solved edit bittornado-0.3.8.ebuild and comment out
RDEPEND="X? ( >=dev-python/wxpython-2.4 )

now my firefox refuses to add a simple extension I've edited mimeTypes.rdf but with still no good result indeed it try to download it gosh...

  <RDF:Seq RDF:about="urn:mimetypes:root">
    <RDF:li RDF:resource="urn:mimetype:application/x-tar"/>
    <RDF:li RDF:resource="urn:mimetype:application/pdf"/>
    <RDF:li RDF:resource="urn:mimetype:application/msword"/>
    <RDF:li RDF:resource="urn:mimetype:application/"/>
    <RDF:li RDF:resource="urn:mimetype:application/x-java-jnlp-file"/>
    <RDF:li RDF:resource="urn:mimetype:application/x-bittorrent"/>
  <RDF:Description RDF:about="urn:mimetype:handler:application/x-bittorrent"
<NC:externalApplication RDF:resource="urn:mimetype:externalApplication:application/x-bittorrent"/>
  <RDF:Description RDF:about="urn:mimetype:externalApplication:application/x-bittorrent"
                   NC:prettyName="bittorrent" />

Author:  alpha [ Tue Apr 19, 2005 9:02 am ]
Post subject:  it works

The edit of RDF for mimetypes was correct and just full restart made it work (not just switching user in profile manager).
Very nice application I love it :)

So I may have took the longest path to solve but I think
1) there is some simple packaging issue if by mistake you install bittorrent first
2) In my case firefox refused to associate a new mimetype (don't know why) ... If you have the same problem just edit the mimetype.rdf of your profile like I did.


Is anyone reading my post :?:

Page 2 of 3 All times are UTC - 7 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group