the forums at degreez.net

It is currently Thu Feb 22, 2018 4:32 am

All times are UTC - 7 hours [ DST ]




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 9 posts ] 
Author Message
PostPosted: Thu May 05, 2005 10:02 pm 
If I start a download with more than one file in it and flag all but one file as 'Download Never' (in the details menu), cancel the download and then resume it later I get an error saying that one of the files flagged as 'Download Never' can't be opened and bittornado then locks up.

Example:
a torrent downloads 3 files: foo.mpg, bar.avi and baz.iso

1) Start the download.
2) Flag foo.mpg and bar.avi as 'Download Never'
3) Stop the download (ie press cancel button)
4) Resume the download

Expected result: baz.iso picks up from where it left off and foo.mpg and bar.avi are ignored and not touched.

Actual result: baz.iso picks up from where it left off BUT after a short while
bittornado returns the following error:

Code:
IO Error: unable to open /path/to/foo.mpg: [Errno 2] No such file or directory:
        '/path/to/foo.mpg'


When a torrent is canceled files marked as 'Download Never' are deleted from the target directory and so obviously can't be opened. Prehaps the empty dummy files initially created when the torrent is first started shouldn't be deleted until all the files marked for download have finished downloading.[/code]


Top
  
 
 Post subject:
PostPosted: Thu May 05, 2005 10:15 pm 
I also get this problem every now and then when I pick and choose files with 'Download Never'. It usually doesn't hurt anything; it'll just flag the IO error and crash the torrent... Reopening the torrent will restore all the files (including the empty ones) and you have to adjust their priorities all over again or else it'll start to download all the files [e.g. those marked as Download Never get reset]. While seemingly harmless, it's unnecessarily tedious and it would be nice to have this fixed up in some way in the next release(s).


Top
  
 
 Post subject: fixing this
PostPosted: Fri May 13, 2005 12:23 pm 
When this happens to you, you kill the torrent off, start it up, mark the files that you dont want to download, and then it works again?


Top
  
 
 Post subject:
PostPosted: Fri May 13, 2005 1:52 pm 
Basically, yes. I've just tested it with 0.3.10SP and made a step by step log of my actions after following your example:

1. Started a multi-file torrent.
2. Selected 5 of the 16 files to download, the rest are set to download never.
3. Hit cancel after about 10% completion.
4. All but the 5 files are deleted (instead of just empty files, they are removed altogether)
5. Relaunched torrent.
6. Files remain properly flagged, but IO error is eventually generated trying to open a file that is set to 'Download Never'.
7. Hit cancel.
8. Hit CTRL-SHIFT-ESC to bring up Task Manager. Close the btdownloadgui.exe process that is stuck.
9. Reload Torrent.
10. All files are unflagged so I adjust them back to the ones I want.
11. Torrent finishes successfully.

Once I get to step 10, it's basically step 1 all over again (it recreates all the deleted files again) except my 5 partial files still retain their downloaded pieces.

I'm guessing when the torrent downloads a piece that contains parts of two files and one of the files can't be opened -- it just crashes. Hopefully this error will be craftily resolved in a future release if it already hasn't been in versions 3.11 or 3.12.


Top
  
 
 Post subject: Similar to my problem...
PostPosted: Thu May 26, 2005 1:30 pm 
I do the same thing as Araym (BT takes around 30 sec. to 30 min. to stop saying it hit an error accessing my folder, I close it[program and process], restart, reflag the files I don't want, and it works fine)

My problem is I lose 3% to 20% of the file I want when that happens. Last time, I lost 60% of the file. (you can imagine my reaction to that).

If Bittornado 3.12 fixed this, please by all means tell me.


Top
  
 
 Post subject:
PostPosted: Fri May 27, 2005 3:21 pm 
0.3.12 has this problem as well.


Top
  
 
 Post subject:
PostPosted: Fri Jul 20, 2007 2:26 pm 
Offline

Joined: Fri Jul 20, 2007 2:21 pm
Posts: 5
0.3.17 has the same problem. Apparently a possible patch has been posted in this thread:
Forum=Major Problems, Thread=IO Error using pre-allocate and priority list
but I have no idea how to add that patch to the program. :(

(too bad I can't just link to the thread so you don't have to dig thru the forum for it, but links are apparently not allowed in posts)


Top
 Profile  
 
 Post subject:
PostPosted: Thu Aug 23, 2007 4:03 pm 
Offline

Joined: Thu Mar 23, 2006 6:40 pm
Posts: 67
Amberwolf wrote:
0.3.17 has the same problem. Apparently a possible patch has been posted in this thread:
Forum=Major Problems, Thread=IO Error using pre-allocate and priority list
but I have no idea how to add that patch to the program. :(

(too bad I can't just link to the thread so you don't have to dig thru the forum for it, but links are apparently not allowed in posts)


Top
 Profile  
 
 Post subject:
PostPosted: Thu Aug 23, 2007 4:10 pm 
Offline

Joined: Thu Mar 23, 2006 6:40 pm
Posts: 67
Anonymous wrote:
0.3.12 has this problem as well.

SHADOW DON'T CARE SO SHUT YOUR HOLE


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 9 posts ] 

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group